Sale!

Whitfield Profile 20 & 30 – Optima 2 & 3 – Traditions 300 Series – Exhaust Motor

5 out of 5 based on 2 customer ratings
(2 customer reviews)

$164.00

Product Description

Whitfield Profile 20 & 30 – Optima 2 & 3 – Traditions 300 Series – Exhaust Motor

FAST FREE DELIVERY  – Priority Mail 2 to 3 Days (USA Only )

Factory OEM # 12050011 Whitfield – Lennox

PSP SKU # PP7601

FASCO Factory Replacement Motor – 3000RPM, 115v, 60Hz

Maintenance Free – Sealed Lubricated Bearings – No Oiling Needed

Whisper Quiet on all Heat Settings

7″ Mounting Hub – Easy DIY Installer Change Out

Cooling Fins Extends Motor Life – 12 Fin Impeller

Includes High Heat Vibration Free Gasket

Fits the following Models:

  • Profile 20 FS
  • Profile 30 FS & Insert
  • Optima 2 FS
  • Optima 3 FS & Insert
  • Quest Plus FS & Insert
  • Traditions 300P, 301P, 305P, 308P

1 – Year Warranty

2 reviews for Whitfield Profile 20 & 30 – Optima 2 & 3 – Traditions 300 Series – Exhaust Motor

  1. 5 out of 5

    (verified owner):

    Andy’s the greatest, know exactly what he’s talking about, he’s the sales rep for parts and knowledge (esp for how to for dummies like me) to help you get things up and running again.
    We are “customers for life”. (Hope you’re not sorry for that one… lol) Fastest shipping ever. Part works great for our whitfield 30 fs.
    easy in stall up and running in Minutes.
    utes

  2. 5 out of 5

    (verified owner):

    Very well packaged, fast shipping…what more can you ask for? I had a lot problems with my stove – it just didn’t seem to run like it should. Always blowing smoke into the room on startup, the glass getting smoked up just a day or two after cleaning. I had no idea what the problem was. Then the exhaust motor started squealing when it was running, so I started keeping an eye on it. Then one day as I was watching it as it started up, the motor didn’t come on when the stove did. Finally, the problem was exposed.
    It only took a few minutes to change the two motors. When I turned the stove on, WOW, what a difference this made! I can’t believe it took me so long to figure this out. Now it runs like it did when it was first installed. THANKS guys and/or gals!

Add a review